Manager 업데이트 방법을 알 수 있을까요?



  • ※ 이 글은 기존에 있었던 문의 사항을 재구성하여 정리한 것입니다.

    매니저 2.0.6.20190909 빌드에서 2.22.1.20191004 로 업데이트 시 아래와 같은 메시지가 발생됩니다.
    업데이트 방법을 알 수 있을까요?

    ============== catalina log ===============
    Caused by: org.flywaydb.core.api.FlywayException: Validate failed. Detected resolved migration not applied to database: 3.3.11
    at org.flywaydb.core.Flyway.doValidate(Flyway.java:1108)
    at org.flywaydb.core.Flyway.access$300(Flyway.java:62)
    at org.flywaydb.core.Flyway$1.execute(Flyway.java:1012)
    at org.flywaydb.core.Flyway$1.execute(Flyway.java:1006)
    at org.flywaydb.core.Flyway.execute(Flyway.java:1418)
    at org.flywaydb.core.Flyway.migrate(Flyway.java:1006)
    at org.springframework.boot.autoconfigure.flyway.FlywayMigrationInitializer.afterPropertiesSet(FlywayMigrationInitializer.java:66)
    at org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.invokeInitMethods(AbstractAutowireCapableBeanFactory.java:1692)
    at org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.initializeBean(AbstractAutowireCapableBeanFactory.java:1630)
    ... 29 more



  • 위와 같은 오류가 발생하는 경우 HeidiSQL로 DB에 접속 후 automateone -> schema_version에 Data를 보시면 version이 4.0인 행이 있습니다.
    Version이 4.0인 행을 제거 후 다시 서버를 재부팅 시키면 해당 문제를 해결하실 수 있습니다.

    Manager 업데이트 방법을 알 수 있을까요.jpg


Log in to reply