버전에 따라 Trainer를 Command Line으로 실행할 수 없는 경우도 있나요?



  • ※ 이 글은 기존에 있었던 문의 사항을 재구성하여 정리한 것입니다.

    다름이 아니라 현재 Build4.12.5.20190405 버전의 AO Trainer를 Command Line 을 통해 실행할 수 있는지 확인 중에 있습니다.
    구 버전의 Trainer 는 정상적인 실행을 확인하였으나, 해당 버전(Build4.12.5.20190405)의 Trainer 에서는 CLI 실행이 되지않습니다.
    해당 현상에 대해 업데이트가 있었는지, 확인 가능한 사항이 있는지 궁금합니다.



  • AO버전 4.12.3 이하버전에서 Command Line 사용시 기존 사용하시는 명령을 사용하시어 사용 가능합니다.
    구 방식) AutomateOne.exe script -s c:\gridoneScript.xml -g local -d local

    만약 AO 4.12.4~4.12.6 버전에서 Command Line 사용시에는 바뀐 명령으로 사용하셔야 합니다. 사용 방법은 아래와 같습니다.
    신 방식) AutomateOne.exe "script" -s "스크립트 파일 경로" -tc "스크립트명" -tid "실행ID" -g "local" -d "local"
    "script" : 고정값 / -s : 스크립트 경로 / -tc : log 폴더내 로그 폴더 명 생성
    -tid : 스크립트 실행 ID. 중복되지 않아야 하며, 중복되면 로그 폴더를 덮어씀
    -g : 고정값 / -d : 고정값
    (아래 이미지는 사용 예제입니다. 참고 부탁드립니다. )

    버전에 따라 Trainer를 Command Line으로 실행할 수 없는 경우도 있나요.jpg


Log in to reply